Configuration Example: Multi-Area IS-IS
Figure 4-2 shows the network topology for the configuration that follows, which demonstrates how to configure Integrated IS-IS using the commands covered in this chapter.
Figure 4-2 Multi-Area IS-IS
Mazatlan Router
Router>enable |
Moves to privileged mode. |
Router#configure terminal |
Moves to global configuration mode. |
Router(config)#hostname Mazatlan |
Assigns the host name to the router. |
Mazatlan(config)#interface fastethernet 0/0 |
Enters interface configuration mode. |
Mazatlan(config-if)#ip address 192.168.0.1 255.255.255.0 |
Assigns an IP address and netmask. |
Mazatlan(config-if)#ip router isis |
Enables IS-IS routing on this interface. |
Mazatlan(config-if)#no shutdown |
Enables the interface. |
Mazatlan(config-if)#int loopback 0 |
Moves to interface configuration mode. |
Mazatlan(config-if)#ip address 172.16.10.1 255.255.255.0 |
Assigns an IP address and netmask. |
Mazatlan(config-if)#ip router isis |
Enables IS-IS routing on this interface. |
Mazatlan(config-if)#interface serial 0/0 |
Moves to interface configuration mode. |
Mazatlan(config-if)#ip address 10.10.10.1 255.255.255.252 |
Assigns an IP address and netmask. |
Mazatlan(config-if)#ip router isis |
Enables IS-IS routing on this interface. |
Mazatlan(config-if)#clock rate 56000 |
Sets the clock rate. |
Mazatlan(config-if)#no shutdown |
Enables the interface. |
Mazatlan(config-if)#exit |
Returns to global configuration mode. |
Mazatlan(config)#router isis |
Enables the IS-IS routing process. |
Mazatlan(config-router)#net 49.0001.1111.1111.1111.00 |
Configures the NET. |
Mazatlan(config-router)#is-type level-1-2 |
The router will perform both Level 1 and 2 routing. |
Mazatlan(config-router)#exit |
Returns to global configuration mode. |
Mazatlan(config)#exit |
Returns to privileged mode. |
Mazatlan#copy running-config startup-config |
Saves the configuration to NVRAM. |
Acapulco Router
Router>enable |
Moves to privileged mode. |
Router#configure terminal |
Moves to global configuration mode. |
Router(config)#hostname Acapulco |
Assigns the host name to the router. |
Acapulco(config)#interface fastethernet 0/0 |
Enters interface configuration mode. |
Acapulco(config-if)#ip address 192.168.0.2 255.255.255.0 |
Assigns an IP address and netmask. |
Acapulco(config-if)#ip router isis |
Enables IS-IS routing on this interface. |
Acapulco(config-if)#no shut |
Enables the interface. |
Acapulco(config-if)#interface loopback 0 |
Moves to interface configuration mode. |
Acapulco(config-if)#ip address 172.16.20.1 255.255.255.0 |
Assigns an IP address and netmask. |
Acapulco(config-if)#ip router isis |
Enables IS-IS routing on this interface. |
Acapulco(config-if)#exit |
Returns to global configuration mode. |
Acapulco(config)#router isis |
Enables the IS-IS routing process. |
Acapulco(config-router)#net 49.0001.2222.2222.2222.00 |
Configures the NET. |
Acapulco(config-router)#is-type level-1 |
The router will perform Level 1 routing only. |
Acapulco(config-router)#exit |
Returns to global configuration mode. |
Acapulco(config)#exit |
Returns to privileged mode. |
Acapulco#copy running-config startup-config |
Saves the configuration to NVRAM. |
Cancun Router
Router>enable |
Moves to privileged mode. |
Router#configure terminal |
Moves to global configuration mode. |
Router(config)#hostname Cancun |
Assigns a host name to the router. |
Cancun(config)#interface serial 0/0 |
Enters interface configuration mode. |
Cancun(config-if)#ip address 10.10.10.2 255.255.255.252 |
Assigns an IP address and netmask. |
Cancun(config-if)#ip router isis |
Enables IS-IS routing on this interface. |
Cancun(config-if)#no shutdown |
Starts the interface. |
Cancun(config-if)#interface loopback 0 |
Moves to interface configuration mode. |
Cancun(config-if)#ip address 172.16.30.1 255.255.255.0 |
Assigns an IP address and netmask. |
Cancun(config-if)#ip router isis |
Enables IS-IS routing on this interface. |
Cancun(config-if)#exit |
Returns to global configuration mode. |
Cancun(config)#router isis |
Enables the IS-IS routing process. |
Cancun(config-router)#net 49.0002.3333.3333.3333.00 |
Configures the NET. |
Cancun(config-router)#is-type level-2-only |
Router will perform Level 2 routing only. |
Cancun(config-router)#exit |
Returns to global configuration mode. |
Cancun(config)#exit |
Returns to privileged mode. |
Cancun#copy running-config startup-config |
Saves the configuration to NVRAM. |