Configuration Example: IPv6 Inter-VLAN Communication
Figure 3-2 shows the network topology for the configuration that follows, which demonstrates how to configure IPv6 inter-VLAN communication using commands covered in this chapter. Some commands used in this configuration are from previous chapters.
Figure 3-2 Network Topology for IPv6 Inter-VLAN Communication Configuration
ISP Router
Router(config)# hostname ISP |
Sets the hostname |
ISP(config)# ipv6 unicast-routing |
Enables IPv6 routing |
ISP(config)# interface loopback 0 |
Enters interface configuration mode |
ISP(config-if)# ipv6 address 2001:db8:0:a::1/64 |
Assigns an IPv6 address |
ISP(config-if)# interface serial 0/0/0 |
Enters interface configuration mode |
ISP(config-if)# clock rate 4000000 |
Assigns a clock rate to the interface; DCE cable is plugged into this interface |
ISP(config-if)# ipv6 address 2001:db8:0:8::1/64 |
Assigns an IPv6 address |
ISP(config-if)# no shutdown |
Turns on this interface |
ISP(config-if)# exit |
Exits into global configuration mode |
ISP(config)# ipv6 route ::/0 serial 0/0/0 |
Creates a default static route to return traffic from the Internet |
ISP(config)# end |
Returns to privileged EXEC mode |
CORP Router
Router(config)# hostname CORP |
Sets the hostname |
CORP(config)# ipv6 unicast-routing |
Enables global IPv6 forwarding |
CORP(config)# ipv6 router ospf 1 |
Enters OSPFv3 programming mode |
CORP(config-rtr)# router-id 192.168.1.1 |
Assigns a router ID for the OSPFv3 process |
CORP(config-rtr)# default- information originate |
Adds any default routing information to the OSPFv3 updates |
CORP(config-rtr)# exit |
Exits to global configuration mode |
CORP(config)# interface gigabitethernet 0/0.1 |
Enters subinterface programming mode |
CORP(config-subif)# encapsulation dot1q 1 native |
Assigns 802.1Q as the trunking protocol and associates VLAN 1 to this subinterface |
CORP(config-subif)# ipv6 address 2001:db8:0:2::1/64 |
Assigns an IPv6 address |
CORP(config-subif)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
CORP(config-subif)# interface gigabitethernet 0/0.30 |
Enters subinterface programming mode |
CORP(config-subif)# encapsulation dot1q 30 |
Assigns 802.1Q as the trunking protocol and associates VLAN 30 to this subinterface |
CORP(config-subif)# ipv6 address 2001:db8:0:30::1/64 |
Assigns an IPv6 address |
CORP(config-subif)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
CORP(config-subif)# interface gigabitethernet 0/0.40 |
Enters subinterface programming mode |
CORP(config-subif)# encapsulation dot1q 40 |
Assigns 802.1Q as the trunking protocol and associates VLAN 40 to this subinterface |
CORP(config-subif)# ipv6 address 2001:db8:0:40::1/64 |
Assigns an IPv6 address |
CORP(config-subif)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
CORP(config-subif)# interface gigabitethernet 0/0.50 |
Enters subinterface programming mode |
CORP(config-subif)# encapsulation dot1q 50 |
Assigns 802.1Q as the trunking protocol and associates VLAN 50 to this subinterface |
CORP(config-subif)# ipv6 address 2001:db8:0:50::1/64 |
Assigns an IPv6 address |
CORP(config-subif)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
CORP(config-subif)# interface gigabitethernet 0/1 |
Enters interface programming mode |
CORP(config-if)# ipv6 address 2001:db8:0:7::2/64 |
Assigns an IPv6 address |
CORP(config-if)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
CORP(config-if)# interface gigabitethernet 0/0 |
Enters interface programming mode |
CORP(config-if)# no shutdown |
Turns this interface on |
CORP(config-if)# interface serial 0/0/0 |
Enters interface programming mode |
CORP(config-if)# ipv6 address 2001:db8:0:8::2/64 |
Assigns an IPv6 address |
CORP(config-if)# no shutdown |
Turns this interface on |
CORP(config-if)# exit |
Exits to global configuration programming mode |
CORP(config)# ipv6 route ::/0 serial 0/0/0 |
Creates a default static route pointing to the ISP |
CORP(config)# end |
Returns to privileged EXEC mode |
L2Switch2 (Catalyst 2960)
Switch(config)# hostname L2Switch2 |
Sets the hostname |
L2Switch2(config)# sdm prefer dual-ipv4-and-ipv6 default |
Configures the Switching Database Manager (SDM) on the switch to optimize memory and operating system for both IPv4 and IPv6 Layer 3 forwarding |
L2Switch2(config)# vlan 30,40,50 |
Creates VLANs 30, 40, and 50 |
L2Switch2(config-vlan)# exit |
Exits VLAN configuration mode |
L2Switch2(config)# interface fastethernet 0/5 |
Enters switchport interface configuration mode |
L2Switch2(config-if)# switchport mode trunk |
Sets this port to trunk unconditionally |
L2Sw2(config-if)# interface range fastethernet 0/12 - 14 |
Enters switchport configuration mode for a range of switch ports |
L2Switch2(config-if-range)# switchport mode access |
Sets these ports to be access ports |
L2Switch2(config-if-range)# switchport access vlan 30 |
Assigns these ports to VLAN 30 |
L2Switch2(config-if-range)# interface range fastethernet 0/15 - 18 |
Enters switchport configuration mode for a range of switch ports |
L2Switch2(config-if-range)# switchport mode access |
Sets these ports to be access ports |
L2Switch2(config-if-range)# switchport access vlan 40 |
Assigns these ports to VLAN 20 |
L2Switch2(config-if-range)# interface range fastethernet 0/19 - 22 |
Enters switchport configuration mode for a range of switchports |
L2Switch2(config-if-range)# switchport mode access |
Sets these ports to be access ports |
L2Switch2(config-if-range)# switchport access vlan 50 |
Assigns these ports to VLAN 50 |
L2Switch2(config-if-range)# interface vlan1 |
Enters interface configuration mode for the management VLAN |
L2Switch2(config-if)# ipv6 address 2001:db8:0:2::/64 |
Assigns an IPv6 address |
L2Switch2(config-if)# no shutdown |
Turns this interface on |
L2Switch2(config-if)# exit |
Exits to global configuration mode |
L2Switch2(config)# ipv6 route ::/0 2001:db8:0:2::1 |
Assigns a default gateway |
L2Switch2(config)# end |
Returns to privileged EXEC mode |
L3Switch1 (Catalyst 3650)
Switch(config)# hostname L3Switch1 |
Sets the hostname |
L3Switch1(config)# ipv6 unicast-routing |
Enables IPv6 forwarding |
L3Switch1(config)# vlan 10,20 |
Creates VLANs 10 and 20 |
L3Switch1(config-vlan)# exit |
Exits VLAN configuration mode |
L3Switch1(config)# interface gigabitethernet 1/0/1 |
Enters interface configuration mode |
L3Switch1(config-if)# switchport mode trunk |
Sets this port to trunk unconditionally |
L3Switch1(config-if)# ipv6 router ospf 1 |
Enters OSPFv3 configuration mode |
L3Switch1(config-rtr)# router-id 192.168.1.2 |
Assigns the OSPFv3 router ID |
L3Switch1(config-rtr)# exit |
Exits to global configuration mode |
L3Switch1(config)# interface gigabitethernet 1/0/24 |
Enters switchport interface configuration mode |
L3Switch1(config-if)# no switchport |
Changes this Layer 2 switch port to a Layer 3 routed port |
L3Switch1(config-if)# ipv6 address 2001:db8:0:7::1/64 |
Assigns an IPv6 address |
L3Switch1(config-if)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
L3Switch1(config-if)# interface vlan1 |
Enters interface configuration mode for VLAN 1 |
L3Switch1(config-if)# ipv6 address 2001:db8:0:1::1/64 |
Assigns an IPv6 address |
L3Switch1(config-if)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
L3Switch1(config-if)# interface vlan10 |
Enters interface configuration mode for VLAN 10 |
L3Switch1(config-if)# ipv6 address 2001:db8:0:10::1/64 |
Assigns an IPv6 address |
L3Switch1(config-if)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
L3Switch1(config-if)# interface vlan20 |
Enters interface configuration mode for VLAN 20 |
L3Switch1(config-if)# ipv6 address 2001:db8:0:20::1/64 |
Assigns an IPv6 address |
L3Switch1(config-if)# ipv6 ospf 1 area 0 |
Specifies this as an interface that will participate in OSPFv3 |
L3Switch1(config-if)# end |
Returns to privileged EXEC mode |
L2Switch1 (Catalyst 2960)
Switch(config)# hostname L2Switch1 |
Sets the hostname |
L2Switch1(config)# sdm prefer dual-ipv4-and-ipv6 default |
Configures the Switching Database Manager on the switch to optimize memory and operating system for both IPv4 and IPv6 Layer 3 forwarding |
L2Switch1(config)# vlan 10,20 |
Creates VLANs 10 and 20 |
L2Switch1(config-vlan)# exit |
Exits VLAN configuration mode |
L2Switch1(config)# interface gigabitethernet 0/1 |
Enters switchport interface configuration mode |
L2Switch1(config-if)# switchport mode trunk |
Sets this port to trunk unconditionally |
L2Switch1(config-if)# interface range fastethernet 0/12 - 14 |
Enters switchport configuration mode for a range of switch ports |
L2Switch1(config-if-range)# switchport mode access |
Sets these ports to be access ports |
L2Switch1(config-if-range)# switchport access vlan 10 |
Assigns these ports to VLAN 10 |
L2Switch1(config-if-range)# interface range fastethernet 0/15 - 18 |
Enters switchport configuration mode for a range of switch ports |
L2Switch1(config-if-range)# switchport mode access |
Sets these ports to be access ports |
L2Switch1(config-if-range)# switchport access vlan 20 |
Assigns these ports to VLAN 20 |
L2Switch1(config-if-range)# interface vlan1 |
Moves to interface configuration mode |
L2Switch1(config-if)# ipv6 address 2001:0:0:4::2/64 |
Assigns an IPv6 address |
L2Switch1(config-if)# exit |
Returns to global configuration mode |
L2Switch1(config)# ipv6 route ::/0 2001:db8:0:1::1 |
Assigns a default gateway |
L2Switch1(config)# end |
Returns to privileged EXEC mode |