Configuration Example: EIGRP
Figure 8-1 illustrates the network topology for the configuration that follows, which shows how to configure EIGRP using the commands covered in this chapter.
Figure 8-1 Network Topology for EIGRP Configuration
Austin Router
Austin>enable |
Moves to privileged mode. |
Austin#configure terminal |
Moves to global configuration mode. |
Austin(config)#interface serial 0/0/0 |
Enters interface configuration mode. |
Austin(config-if)#ip address 172.16.20.1 255.255.255.0 |
Assigns the IP address and netmask. |
Austin(config-if)#ip |
Enables MD5 authentication in EIGRP packets. |
Austin(config-if)#ip |
Enables authentication of EIGRP packets. |
Austin(config-if)#no shutdown |
Enables the interface. |
Austin(config-if)#interface fastethernet 0/1 |
Enters interface configuration mode. |
Austin(config-if)#ip address 172.16.10.1 255.255.255.0 |
Assigns the IP address and netmask. |
Austin(config-if)#no shutdown |
Enables the interface. |
Austin(config-if)#router eigrp 100 |
Enables EIGRP routing. |
Austin(config-router)#no auto-summary |
Disables auto-summarization. |
Austin(config-router)#eigrp log-neighbor-changes |
Changes with neighbors will be displayed. |
Austin(config-router)#network 172.16.0.0 |
Advertises directly connected networks (classful address only). |
Austin(config-router)#passive interface fastethernet 0/1 |
Prevents the sending of hello packets out the Fast Ethernet 0/1 interface. No neighbor adjacency will be formed. |
Austin(config-router)#key chain susannah |
Identifies a key chain name, which must match the name configured in interface configuration mode. |
Austin(config-keychain)#key 1 |
Identifies the key number. |
Austin(config-keychain-key)#key-string tower |
Identifies the key string. |
Austin(config-keychain-key)#accept-lifetime 06:30:00 Apr 19 2013 infinite |
Specifies the period during which the key can be received. |
Austin(config-keychain-key)#send-lifetime 06:30:00 Apr 19 2013 09:45:00 Apr 19 2013 |
Specifies the period during which the key can be sent. |
Austin(config-keychain-key)#exit |
Returns to global configuration mode. |
Austin(config)#exit |
Returns to privileged mode |
Austin#copy running-config startup-config |
Saves the configuration to NVRAM. |
Houston Router
Houston>enable |
Moves to privileged mode. |
Houston#configure terminal |
Moves to global configuration mode. |
Houston(config)#interface serial 0/0/1 |
Enters interface configuration mode. |
Houston(config-if)#ip address 172.16.20.2 255.255.255.0 |
Assigns the IP address and netmask. |
Houston(config-if)#ip |
Enables MD5 authentication in EIGRP packets. |
Houston(config-if)#ip |
Enables authentication of EIGRP packets. eddie is the name of the key chain. |
Houston(config-if)#clock rate 56000 |
Sets the clock rate. |
Houston(config-if)#no shutdown |
Enables the interface. |
Houston(config-if)#interface fastethernet 0/1 |
Enters interface configuration mode. |
Houston(config-if)#ip address 172.16.30.1 255.255.255.0 |
Assigns the IP address and netmask. |
Houston(config-if)#no shutdown |
Enables the interface. |
Houston(config-if)#router eigrp 100 |
Enables EIGRP routing. |
Houston(config-router)#no auto-summary |
Disables auto-summarization. |
Houston(config-router)#eigrp log-neighbor-changes |
Changes with neighbors will be displayed. |
Houston(config-router)#network 172.16.0.0 |
Advertises directly connected networks (classful address only). |
Houston(config-router)#passive interface fastethernet 0/1 |
Prevents the sending of hello packets out the Fast Ethernet 0/1 interface. No neighbor |
Houston(config-router)#key chain eddie |
Identifies a key chain name, which must match the name configured in interface |
Houston(config-keychain)#key 1 |
Identifies the key number. |
Houston(config-keychain-key)#key-string tower |
Identifies the key string. |
Houston(config-keychain-key)#accept-lifetime 06:30:00 Apr 19 2013 infinite |
Specifies the period during which the key can be received. |
Houston(config-keychain-key)#send-lifetime 06:30:00 Apr 19 2013 09:45:00 Apr 19 2013 |
Specifies the period during which the key can be sent. |
Houston(config-keychain-key)#exit |
Returns to global configuration mode. |
Houston(config)#exit |
Returns to privileged mode. |
Houston#copy running-config startup-config |
Saves the configuration to NVRAM. |